Yealink W70B Wireless DECT Base Station

Yealink W70B Wireless DECT Base Station

Price$109

Out of stock at MSY

Price checked today

Buy at MSY

We may earn a commission if you buy; it doesn't change your price. Check the price at MSY before you buy. How we make money

Price history

Tracking since today

The price hasn't changed since we started tracking it. We'll show its history once it does.

About this product

Brand
Yealink
Store
MSY
Category
Electronics > Communications > Telephony > Cordless Phones
SKU
72521

Yealink W70B Wireless DECT Base StationThe Yealink W70B is the DECT IP base station for small and medium-sized businesses. Paring with up to a total of 10 Yealink W73H/W76H/W59R/CP935W/color-screen DDPhone (T54W+DD10K) DECT handsets, W70B allows you to enjoy superb mobility and efficient flexibility immediately as well as significantly eliminates additional wiring troubles and charges. A powerful chip ensuring a better and higher performance, this DECT IP base station not only supports up to 10 VoIP accounts and 20 simultaneous calls, but also speeds up its startup and signal connection, provides no perception upgrade, slashes its upgrade downtime as well.Designed in modern and elegant style, this compact DECT IP base station possesses a wire-hidden design, presenting a concise and tidy desk to you even being mounted to the wall. By supporting Opus codec, Yealink W70B consistently delivers excellent and professional audio quality in both high-bandwidth and poor network conditions, comparing with other wideband or narrowband audio codecs.The Yealink W70B DECT IP base station supports efficient provisioning and effortless mass deployment with Yealinks Redirection and Provisioning Service (RPS) and Boot mechanism to help you realize the Zero Touch Provisioning without any complex manual settings, which makes it simple to deploy, easy to maintain and upgrade, saving even more time and IT costs for businesses.SPECIFICATIONS:Phone Features Up to 20 simultaneous calls Up to 10 handsets Up to 10 SIP accounts Up to 6 repeaters per base station (RT30) No Perception Upgrade Paging/Intercom/Auto answer/Dial plan Call hold/Call transfer/Call waiting 3-way conference Switching between calls Mute/Silence/DND Caller ID with name and number Anonymous call/Anonymous call rejection Call forward: Always/Busy/No Answer Speed dial/Voicemail/Redial Message Waiting Indication (MWI) Music on hold (server-based) Local phonebook for up to 1000 entries (store in the base) Remote phonebook/LDAP/XML phonebook Phonebook search/import/export Call history: All/Missed/Placed/Received Direct IP call without SIP proxy Reset to factory, reboot Emergency call Broadsoft directory, BroadSoft call log Broadworks feature key synchronization Shared Call Appearance (SCA) Action URI XML browserManagement Auto-provision via TFTP/FTP/HTTP/HTTPS/RPS Auto-provision with PnP Handset upgrade: OTA (Over-The-Air)/No Perception Configuration: browser/phone/auto-provision Trace package and system log exportAudio Features Full-duplex speakerphone Hearing Aid Compatibility (HAC) compliant FNR (Noise Cancellation) Wideband codec: Opus, G.722 Narrowband codec: PCMU, PCMA, G.726, G.729, G.729A, iLBC VAD, CNG, AGC, PLC, AJB AEC (supported by W53H) Support VQ-RTCPXR (RFC6035), RTCP-XRNetwork Features SIP v1 (RFC2543), v2 (RFC3261) SNTP/NTP VLAN (802.1Q and 802.1P) 802.1x, LLDP STUN Client (NAT Traversal) UDP/TCP/TLS IP assignment: Static/DHCP Support outbound proxy server backupSecurity Open VPN Transport Layer Security (TLS) HTTPS (server/client), SRTP (RFC3711) Digest authentication Secure configuration file via AES encryption Support SHA256/SHA512/SHA384 Three-level configuration mode: Admin/Var/UserDECT Frequency bands:1880 1900 MHz (Europe), 1920 1930 MHz (US) DECT Standards: CAT-iq2.0Interface 1 x RJ45 10/100M Ethernet port Power over Ethernet (IEEE 802.3af), Class 1Physical Features Indoor Range: 50m (in ideal conditions) Outdoor Range: 300m (in ideal conditions) Desktop or wall mountable Energy-saving ECO mode/ECO Mode+ Three LED indicators on W70B:- 1 x Registration LED- 1 x Network Status LED- 1 x Power Indicator LED External Yealink AC adapter:AC 100-240V Input and DC 5V/600mA Output Color:Classic Grey Base station size: 130mm x 100mm x 25.1mm Operating humidity: 10 ~ 95% Operating temperature: 0 ~ +40C (+32~104F)Package Features Package contents:- W70B Base Station- Base Stand- Power Adapter- Ethernet Cable- Quick Start Guide